Usb mouse works 100%, Keytronic USB keyboard plugged to next port does not.

xefe · 339

xefe

  • Newbie
  • *
    • Posts: 20
    • Karma: +0/-0
Hello!
Today is my first day using AROS. I installed Icaros on an old Pentium 4 HP DC5100 small form factor and installation went fine, graphics are working nicely (GMA900) and ac97 audio also works. Not sure about the broadcom ethernet yet as i'm trying to go trough the basics before attempt internet connection.
First weird problem is my mouse works as it should but my usb keytronic keyboard does not. It's a completely normal old usb wired keyboard connected to the same controller as the mouse.

Can somebody help me?

Another thing is, how can i change the desktop wallpaper? After i changed the resolution to 1680x1050 24bit, the default wallpaper vanished and i was left with a black background. I followed a pdf guide but when i click on the workbench icon inside the wandeder applet, Icaros crashes and reboot.

thanks!
« Last Edit: November 09, 2020, 04:56:25 AM by xefe »



deadwood

  • AROS Developer
  • Member
  • *****
    • Posts: 143
    • Karma: +15/-0
You could try opening SYS:Prefs/Trident and see if keyboard is listed there at all. I can't think of a known reason why a keyboard would not be detected. Try another keyboard if you have one or try plugging your keyboard without mouse.



aGGreSSor

  • Junior Member
  • **
    • Posts: 54
    • Karma: +2/-0
    • russian transit
If your motherboard has a ps / 2 port then you can try to connect via an adapter PS/2-USB, such as this



xefe

  • Newbie
  • *
    • Posts: 20
    • Karma: +0/-0
For now, i just ended up using a ps2 keyboard, but i still find it weird that a normal usb wired keyboard does not work just like the mouse.
For networking, while the broadcom netxtreme seems to be listed in the pci devices with an apparent driver installed, i ended up using a regular pci realtek 8139. I could not get a connection with the broadcom...

I got the default wallpaper back by using 16 bit color mode instead of 24 bit. 24 bit made the wallpaper vanish leaving me with a black backgroung and seems to make the wandeder configurator glitch and crash.

OpenGl demos that work seem not to be hardware accelerated. Geoface makes the system crash and no texture filtering working in sdl quake, seems to be in software mode. Isn't GMA900 and 950 supposed to be supported?

thanks.



ntromans

  • Newbie
  • *
    • Posts: 46
    • Karma: +4/-0
For now, i just ended up using a ps2 keyboard, but i still find it weird that a normal usb wired keyboard does not work just like the mouse.
For networking, while the broadcom netxtreme seems to be listed in the pci devices with an apparent driver installed, i ended up using a regular pci realtek 8139. I could not get a connection with the broadcom...

I got the default wallpaper back by using 16 bit color mode instead of 24 bit. 24 bit made the wallpaper vanish leaving me with a black backgroung and seems to make the wandeder configurator glitch and crash.

OpenGl demos that work seem not to be hardware accelerated. Geoface makes the system crash and no texture filtering working in sdl quake, seems to be in software mode. Isn't GMA900 and 950 supposed to be supported?

thanks.

Unfortunately all PCITool does is list the information from the device, it does not imply any driver support, and indeed there are no drivers for Broadcom chipsets so the Realtek was the way to go. It seems slight differences in the Intel chipsets can stop the 3D working - I had a Samsung n145+ netbook which looked like 3D should be supported but wasn't (although 2D was, so I was able to dynamically change resolutions), whereas I've just replaced that motherboard (killed by an overvolting PSU) with a slightly earlier one (Samsung n130) and 3D does work for it, although it's so weak as to not be of much use. I agree it's weird over the keyboard - I haven't found one (including wireless combos) that's ever failed.

Cheers,
Nigel.



xefe

  • Newbie
  • *
    • Posts: 20
    • Karma: +0/-0
Thanks all of you!

I've been trying to change the wallpaper in the wanderer app but it doesn't seem to assume the one i choose. It does not apply it and a reboot does nothing for it as well. I'm doing it by opening the wanderer applet, then going to Appearance tab and clicking on Workbench button. I select another image, one of the defaults,  then wanderer seems to assume it inside the applet, even after reboot, but the desktop always remains the same.

What i am doing wrong?

thank you.

PS: Ok, i got it, had to change GUI mode from magellan to wanderer... Things can get confusing pretty quickly on this one.
« Last Edit: November 09, 2020, 09:20:35 PM by xefe »



paolone

  • Moderator
  • Senior Member
  • *****
    • Posts: 372
    • Karma: +11/-0
If you're using Icaros Desktop with its default file manager (Magellan, not Wanderer), then you have to right-click on a empty space of the desktop and find the background image option in the Settings panel. Changing background with Wanderer when you're using Magellan, or vice versa, won't give the expected result. Unluckily I couldn't find a way to make settings between file managers coherent.


To tell the truth, there would be one: using the same image (as Icaros does by default when you install it) and then simply overwrite that image with one of your choice with a dummy 'change background' selector in /prefs. I'm afraid, however, that people accustomed to normal ways to do this thing would find this complication pointless and irritating. :-(


xefe

  • Newbie
  • *
    • Posts: 20
    • Karma: +0/-0
Oh, i see! thanks.

Today i found out that the Keytronic keyboard is the only one that doesn't work in Aros, while it works flawlessly in other SO's. All my other usb and ps2 keyboards work on Aros though. Strange indeed.

Another problem i'm having is while playing classic games with amibridge/janus-uae2, it forces me to use the cursor keys and Alt for fire and in any game so far i can't use Up and Down while pressing Alt, so for example in Super Cars 2 i can't fire (up and down for front and rear missiles) while accelerating(right Alt key). In turrican i can't jump while firing and so on.
I wouldn't mind using this scheme at all, but it doesn't work for me if i can't use all directional keys and fire at the same time.
I tries several keyboard so far to no avail. Is it a janus bug? Can't i swap the fire key (currently right-Alt) for another? How? I can't seem to find a way to do it..

thanks again.



salvo

  • Legendary Member
  • *****
    • Posts: 650
    • Karma: +9/-0
  • Invalid Civil
at moment janus 1.4 is best choice

Aros on Laptop MSI EX600 , Intel Core Duo 2 2Ghz, 3 Gb Ram, SSD Samsung 860 Evo 240 Gb, Nvidia Geforce 8400m GS 512 Mb "VESA", WiFi Atheros Top!


xefe

  • Newbie
  • *
    • Posts: 20
    • Karma: +0/-0
Tried Super Cars with Janus 1.4, problem still persists.



aGGreSSor

  • Junior Member
  • **
    • Posts: 54
    • Karma: +2/-0
    • russian transit
it forces me to use the cursor keys and Alt for fire and in any game so far i can't use Up and Down while pressing Alt, so for example in Super Cars 2 i can't fire (up and down for front and rear missiles) while accelerating(right Alt key). In turrican i can't jump while firing and so on.
I wouldn't mind using this scheme at all, but it doesn't work for me if i can't use all directional keys and fire at the same time.
I tries several keyboard so far to no avail. Is it a janus bug?
It could be a hardware problem. This behavior was typical for ps/2 keyboards: no more than two keys pressed simultaneously are processed. I remember that in 1995 we laughed a lot about it. I'm not sure about the usb keyboard, but it seems that on cheap usb keyboards, the effect still occurs...

Can't i swap the fire key (currently right-Alt) for another? How? I can't seem to find a way to do it..
We need the sources of this Janus.



deadwood

  • AROS Developer
  • Member
  • *****
    • Posts: 143
    • Karma: +15/-0

Can't i swap the fire key (currently right-Alt) for another? How? I can't seem to find a way to do it..
We need the sources of this Janus.

Here you go: https://sourceforge.net/projects/janus-uae/files/janus-uae/



salvo

  • Legendary Member
  • *****
    • Posts: 650
    • Karma: +9/-0
  • Invalid Civil
Tried Super Cars with Janus 1.4, problem still persists.

you are using whload?

Aros on Laptop MSI EX600 , Intel Core Duo 2 2Ghz, 3 Gb Ram, SSD Samsung 860 Evo 240 Gb, Nvidia Geforce 8400m GS 512 Mb "VESA", WiFi Atheros Top!


xefe

  • Newbie
  • *
    • Posts: 20
    • Karma: +0/-0
you are using whload?
[/quote]

Hi.
I'm just double clicking on the adf, launching trough amibridge.
But also tried manually opening janus 1.4 and making a custom config file for the game.
Games been working fine both ways, it's just the up/down cursor conflicting with right Alt. Tried 4 keyboards already, one ps2 and 3 usb, all wired.

Thanks!



salvo

  • Legendary Member
  • *****
    • Posts: 650
    • Karma: +9/-0
  • Invalid Civil
yes i don't use icaros desktop janus-ua and i launch it as a common program and it is not integrated into the system :)

Aros on Laptop MSI EX600 , Intel Core Duo 2 2Ghz, 3 Gb Ram, SSD Samsung 860 Evo 240 Gb, Nvidia Geforce 8400m GS 512 Mb "VESA", WiFi Atheros Top!