Running out of memory when compiling in AROS linux hosted

amigamia · 1030

deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 96
    • Karma: +6/-0
Reply #15 on: June 09, 2020, 11:39:51 PM
Do

Code: [Select]
cd AROS/contrib
git branch

and paste what you got please.



amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #16 on: June 10, 2020, 04:48:15 AM
Code: [Select]
vinny@iMacX ~/myrepo/AROS/contrib $ git branch
* alt-abiv0
  core


deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 96
    • Karma: +6/-0
Reply #17 on: June 10, 2020, 07:01:55 AM
Well, for some reason you have code mixed between alt-abiv0 branch and core :/

contrib/MultiMedia/libs/flac/ is not even present in alt-abiv0 branch.

I just did
Code: [Select]
$ git clone https://github.com/deadw00d/contrib contrib
$ cd contrib
$ git checkout alt-abiv0

And didn't get "contrib/MultiMedia/libs/flac/" directory. Can you try again?



amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #18 on: June 10, 2020, 07:53:56 PM
I may have messed something up when I did these steps:

Code: [Select]
Clone this repostitory (https://github.com/deadw00d/contrib) into directory named 'contrib' and then checkout branch alt-abiv0
Copy the contrib directory into /home/vinny/myrepo/AROS directory

I cloned the repo while I was inside ~myrepo and then checked the branch while in there. I then copied the folder contrib in /home/vinny/myrepo/AROS

I am going to remove it from both and try again

Here is the terminal window log:

Code: [Select]
vinny@iMacX ~ $ git clone https://github.com/deadw00d/contrib contrib
Cloning into 'contrib'...
remote: Enumerating objects: 917, done.
remote: Counting objects: 100% (917/917), done.
remote: Compressing objects: 100% (633/633), done.
remote: Total 114665 (delta 357), reused 572 (delta 277), pack-reused 113748
Receiving objects: 100% (114665/114665), 162.82 MiB | 3.34 MiB/s, done.
Resolving deltas: 100% (65630/65630), done.
Checking connectivity... done.
Checking out files: 100% (17516/17516), done.
vinny@iMacX ~ $ cd contrib/
vinny@iMacX ~/contrib $ git checkout alt-abiv0
Branch alt-abiv0 set up to track remote branch alt-abiv0 from origin.
Switched to a new branch 'alt-abiv0'
vinny@iMacX ~/contrib $
« Last Edit: June 10, 2020, 08:02:49 PM by amigamia »



amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #19 on: June 10, 2020, 08:09:50 PM
looks like that did the trick:


deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 96
    • Karma: +6/-0
Reply #20 on: June 10, 2020, 09:13:57 PM
Good, let me know if you run into any other issues.



amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #21 on: June 10, 2020, 10:03:46 PM
Stopped again but this time much further down:

Code: [Select]
Trying     /home/vinny/myrepo/portssources/icu4c-4_2_1-src.tgz...
Trying     /home/vinny/myrepo/alt-abiv0-linux-i386/bin/linux-x86_64/Ports/host/icu4c/icu4c-4_2_1-src-aros.diff...
Unpacking  `icu4c-4_2_1-src.tgz'...

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
fetch: Error while unpacking `icu4c-4_2_1-src.tgz'.
mmakefile:2528: recipe for target 'crosstools-icu--fetch' failed

I deleted the offending file but in downloading again it stops right in the middle:

Code: [Select]
Length: unspecified [text/html]
Saving to: ‘/home/vinny/myrepo/portssources/icu4c-4_2_1-src.tgz.tmp’

/home/vinny/myrepo/ports     [ <=>                               ]  44.46K  --.-KB/s    in 0.03s   

2020-06-10 16:05:58 (1.36 MB/s) - ‘/home/vinny/myrepo/portssources/icu4c-4_2_1-src.tgz.tmp’ saved [45528]

Trying     /home/vinny/myrepo/alt-abiv0-linux-i386/bin/linux-x86_64/Ports/host/icu4c/icu4c-4_2_1-src-aros.diff...
Unpacking  `icu4c-4_2_1-src.tgz'...
« Last Edit: June 10, 2020, 10:12:31 PM by amigamia »



deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 96
    • Karma: +6/-0
Reply #22 on: June 10, 2020, 10:11:38 PM
Seems like the downloaded icu4c-4_2_1-arc.tgz is somehow damaged. Does it work when you unpack it manually?



amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #23 on: June 10, 2020, 10:26:40 PM
Downloaded the file manually and placed it in its destination folder and it's moving along now...


amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #24 on: June 10, 2020, 11:05:28 PM
Spoke too soon. Ran for a while and it stopped here:

Code: [Select]
Linking    AROS/Extras/Emu/UAE/uae...
[MMAKE] Building AROS.contrib-setup-dirs
[MMAKE] Making contrib-setup-dirs in
mmakefile:3: /home/vinny/myrepo/AROS/config/aros-contrib.cfg: No such file or directory
make[1]: *** No rule to make target '/home/vinny/myrepo/AROS/config/aros-contrib.cfg'.  Stop.
[MMAKE] make --no-print-directory TOP=/home/vinny/myrepo/alt-abiv0-linux-i386 SRCDIR=/home/vinny/myrepo/AROS CURDIR= TARGET=contrib-setup-dirs --file=mmakefile contrib-setup-dirs failed: 512
[MMAKE] Error: Error while running make in : No such file or directory
Makefile:203: recipe for target 'contrib' failed
make: *** [contrib] Error 10


deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 96
    • Karma: +6/-0
Reply #25 on: June 11, 2020, 09:02:36 AM
This again suggests you have somewhere files from "core" branch of contrib instead of "alt-abiv0"

Do this to find them:
Code: [Select]
cd AROS
grep -rnw '.' -e 'aros-contrib.cfg'



amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #26 on: June 14, 2020, 04:03:51 AM
Hi amigamia,


Your file is there, thx.


You can press the uploads link (all the way up at the top, somewhere in the middle) and read that besides your upload, that there are a few others "waiting for approval".  ;)


It sometimes takes a little time for them files to get the approval stamp.

How do I replace the file that is in the uploads waiting for approval? The one I uploaded seemed to have a bug that caused to make it crash right before starting to play. I have since recompiled it and tested on my Dell Latitude D520 with latest Icaros installed.


amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #27 on: June 14, 2020, 04:07:12 AM
Hi deadwood,

I ended up scrapping the whole myrepo as it was becoming too much of a pain in my rear and it was starting to take too much time to troubleshoot. After some struggle, I ended up installin the latest version of Icaros on a Dell Latitude D520 as Nikos had suggested in the past. Much to my surprise, it was much easier to run the makefile from the shell and with minor changes to it. OpenTyrian compiled with no errors and during the running test it worked flawlessly.

Posting this reply from OWB on Icaros on Dell Latitude D520  :D


magorium

  • Member
  • ***
    • Posts: 151
    • Karma: +2/-0
  • Convicted non contributor
Reply #28 on: June 14, 2020, 09:34:17 AM
How do I replace the file that is in the uploads waiting for approval?
as far as i am able to recollect: you can't  :'(


If the file is approved (in the public list) you can replace it using your credentials. As long as the file is in 'approval' state you either need to contact archives-admin, or upload the new version with another name (it was possible to request a name-change long time ago,  but seeing how not active things are...).


It has been long ago, but have you already tried to upload the new file using the old/previous name ? Perhaps there have been some improvements at the archives-software so that it is allowed/possible these days to replace a waiting upload. But then i guess you wouldn't be asking this question.


Sorry to be the bearer of not so enjoyable news, and hope you are doing fine in these crazy times.


cheers


amigamia

  • Newbie
  • *
    • Posts: 36
    • Karma: +2/-0
    • AROS World
Reply #29 on: June 15, 2020, 09:52:57 PM
@magorium

Hi Magorium, I tried to replace the file but looks like only works if t has been approved already. I guess the best option is to wait, unless the admin is on this forum and I can ask him/her directly?

I have been on the AROS arena again for the summer. I have some time to play and being at home most of the time, has given me more time to spend on AROS.

I am still battling AROSWORLD.ORG and issues with the database since the upgrade but the more I patch the more issues I find. I think I need to just wipe it out and let users register again or just plainly shut it down and spend time here.