AROS 68K Problems

AMIGASYSTEM · 629

AMIGASYSTEM

  • Member
  • ***
    • Posts: 181
    • Karma: +3/-0
on: January 13, 2020, 09:27:34 AM
Nightly Build (2020-01-13) on WinUAE no longer installs on HD, i did not test the previous utime.

The hard disk after initialization is not recognized, and installation does not have the path to DH0

The live CD is unstable you can't change the screen resolution with "use" because it crashes.


No problem with the old Nightly Build :)
« Last Edit: February 04, 2020, 01:31:34 PM by AMIGASYSTEM »



Mazze

  • Newbie
  • *
    • Posts: 19
    • Karma: +0/-0
Reply #1 on: January 13, 2020, 06:47:21 PM
Some fixes which were done for supporting GCC 10 are actually causing problems. That will hopefilly be repaired soon.



AMIGASYSTEM

  • Member
  • ***
    • Posts: 181
    • Karma: +3/-0
Reply #2 on: January 14, 2020, 11:57:56 PM
Problems encountered with bmp.datatypes v41.5 (14.1.2020), with AmigaAMP and Amplifer, crash when loading Skin.

No problems with previous version 41.5 (7-7-2019)



Mazze

  • Newbie
  • *
    • Posts: 19
    • Karma: +0/-0
Reply #3 on: January 15, 2020, 06:38:16 PM
There were some fixes for the BMP datatype.
https://github.com/aros-development-team/AROS/commit/7d015dfd21bf7cf5844ccf7c92b702d13ea3152a

Please try next nightly build.
« Last Edit: January 15, 2020, 10:34:25 PM by Mazze »



AMIGASYSTEM

  • Member
  • ***
    • Posts: 181
    • Karma: +3/-0
Reply #4 on: February 04, 2020, 01:31:19 PM
The HD installation problem seems not to have been solved !

On AROS 68k A problem with keyboard localization was encountered, only the default one works, if you change the language it doesn't work !



AMIGASYSTEM

  • Member
  • ***
    • Posts: 181
    • Karma: +3/-0
Reply #5 on: February 06, 2020, 10:19:22 AM
Floppy "AROS-20200206-amiga-m68k-boot-floppy" crashes when started with KickStart OS3

However the command "boot/amiga/AROSBootstrap ROM boot/amiga/aros.hunk.gz" doesn't work on WinUAE, I guess it doesn't work on genuine Amiga too.



AMIGASYSTEM

  • Member
  • ***
    • Posts: 181
    • Karma: +3/-0
Reply #6 on: February 25, 2020, 08:36:05 PM
I encountered a problem with the PNG.Datatype/Icon.library, the DualPNG icons look bad, if I replace the PNG.Datatype with one from OS3 no problem.

With the icon.libray By Peter Keunecke no problem with AROS native PNG.Datatype



AMIGASYSTEM

  • Member
  • ***
    • Posts: 181
    • Karma: +3/-0
Reply #7 on: March 07, 2020, 10:56:39 AM
I noticed that after exiting a WHDload game the operating system slows down and is no longer able to start an alytp WHDload game or applications such as Dopus4 ;(