AROS 68K Problems

AMIGASYSTEM · 1273

AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
on: January 13, 2020, 09:27:34 AM
Nightly Build (2020-01-13) on WinUAE no longer installs on HD, i did not test the previous utime.

The hard disk after initialization is not recognized, and installation does not have the path to DH0

The live CD is unstable you can't change the screen resolution with "use" because it crashes.


No problem with the old Nightly Build :)
« Last Edit: February 04, 2020, 01:31:34 PM by AMIGASYSTEM »



Mazze

  • Newbie
  • *
    • Posts: 19
    • Karma: +0/-0
Reply #1 on: January 13, 2020, 06:47:21 PM
Some fixes which were done for supporting GCC 10 are actually causing problems. That will hopefilly be repaired soon.



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #2 on: January 14, 2020, 11:57:56 PM
Problems encountered with bmp.datatypes v41.5 (14.1.2020), with AmigaAMP and Amplifer, crash when loading Skin.

No problems with previous version 41.5 (7-7-2019)



Mazze

  • Newbie
  • *
    • Posts: 19
    • Karma: +0/-0
Reply #3 on: January 15, 2020, 06:38:16 PM
There were some fixes for the BMP datatype.
https://github.com/aros-development-team/AROS/commit/7d015dfd21bf7cf5844ccf7c92b702d13ea3152a

Please try next nightly build.
« Last Edit: January 15, 2020, 10:34:25 PM by Mazze »



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #4 on: February 04, 2020, 01:31:19 PM
The HD installation problem seems not to have been solved !

On AROS 68k A problem with keyboard localization was encountered, only the default one works, if you change the language it doesn't work !



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #5 on: February 06, 2020, 10:19:22 AM
Floppy "AROS-20200206-amiga-m68k-boot-floppy" crashes when started with KickStart OS3

However the command "boot/amiga/AROSBootstrap ROM boot/amiga/aros.hunk.gz" doesn't work on WinUAE, I guess it doesn't work on genuine Amiga too.



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #6 on: February 25, 2020, 08:36:05 PM
I encountered a problem with the PNG.Datatype/Icon.library, the DualPNG icons look bad, if I replace the PNG.Datatype with one from OS3 no problem.

With the icon.libray By Peter Keunecke no problem with AROS native PNG.Datatype



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #7 on: March 07, 2020, 10:56:39 AM
I noticed that after exiting a WHDload game the operating system slows down and is no longer able to start an alytp WHDload game or applications such as Dopus4 ;(



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #8 on: June 01, 2020, 12:51:00 AM
"Ahi.device" included in Nightly Build 2020-05-31 generates Guru with Audio and Video programs using "Ahi.device", previous version worked well.

Screenmode (old problem) also crashes on WinUAE when you change resolution



deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 94
    • Karma: +6/-0
Reply #9 on: June 01, 2020, 09:02:04 AM
Can you describe the configuration you are using? I tried today's nightly in FS-UAE 2.8.3 and didn't get any crash when doing "play sound" in AHI preferences. Can you attach a screen shot of crash?



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #10 on: June 01, 2020, 10:08:32 AM
From preference no problem for me too, the propblems come out when using AHI applications.

I enclose a little Video where in the first part you can see the good working of the old version of Ahi.device.

In the second part of the video you will see the Guru generated with new version of Ahi.device with the use of Audio and Video Player

https://drive.google.com/file/d/1abqiEnNxNEN49wLfeug4M3KuLo7jXzno/view?usp=sharing



deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 94
    • Karma: +6/-0
Reply #11 on: June 01, 2020, 12:02:10 PM
Thanks. What I hear is that you get the error BUT sound is working. Is this correct?

If there any place I can download system image you are using (to have the right player software installed and configured)?

EDIT: I was able to trigger this with DAPlayer 1.12
« Last Edit: June 01, 2020, 10:32:25 PM by deadwood »



AMIGASYSTEM

  • Member
  • ***
    • Posts: 191
    • Karma: +5/-0
Reply #12 on: June 02, 2020, 03:42:29 PM
OK, yes audio works anyway, I enclose my latest version of the AROs One 68k "not yet official".

In the LIBS folder you will find the "renamed" native AROS libraries that create problems, replace them with 68k Libraries that work better

In the DEVS folder you can find the AHI.device version working

in Prefs there is an additional version of Screenmode that works a bit better, basically if you try to save a lower resolution or 8 Bit the system goes into Crash !


AROS One 68k 1.2 Preview: Download

Config WinUAE and ROM AROS: Download

« Last Edit: June 05, 2020, 12:11:07 PM by AMIGASYSTEM »



deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 94
    • Karma: +6/-0
Reply #13 on: June 02, 2020, 08:05:51 PM
This is something that I broke with recent changes. I submited a fix for this. Thanks for reporting

https://github.com/aros-development-team/AROS/issues/121



deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 94
    • Karma: +6/-0
Reply #14 on: June 04, 2020, 10:01:57 PM
The fix has been integrated into main AROS tree so the nightly build should work now.