BUG: Alternative icon stays visible also after deselection

amiga23 · 304

amiga23

  • Newbie
  • *
    • Posts: 19
    • Karma: +1/-0
If an icon get's selected, an alternative icon is shown. When the icon gets deselected to original icon is show.

On AROS Workbench, the parts of the alternative icon, that are transparent in the original icon, stay visible. For example glow icons: the glow stays visible. Or folders that open and give a view inside do still show mixed with the closed folder.



miker1264

  • Senior Member
  • ****
    • Posts: 333
    • Karma: +12/-1
Reply #1 on: November 17, 2019, 06:06:40 PM
Which version of AROS are you using? That's very important in order to reproduce the display error.



amiga23

  • Newbie
  • *
    • Posts: 19
    • Karma: +1/-0
Reply #2 on: November 17, 2019, 06:55:10 PM
This board is about AROS on Vampire.
I am using the AROS Version that is provided in the Vampire Core 7113. I am using OS3.x executables. So AROS ROM and OS3.x binaries. The About window states Kickstart 51.51 Workbench version 45.5.

I know it is difficult to reproduce as there is no issue tracking system, no clear versioning, no way to build AROS myself, no labels, no release notes, no way to debug .... But I can only report, developers have to think about how to organize and make their lifes easier, or simply ignore.

But this is now already offtopic, which is the biggest issue of forums.

I would propose to use something like codeberg.org to have the code, the issues, the tags, the release notes and the pull requests in one place. Would make collaboration much easier.



AMIGASYSTEM

  • Member
  • ***
    • Posts: 113
    • Karma: +2/-0
Reply #3 on: November 17, 2019, 08:07:39 PM
I did not understand the problem well, if you refer to the graphic artifacts when you drag an icon, that is an old problerma that before or more will fix.
If you are referring to the arrangement of the icons, AROS 68k has a function that automatically fixes the icons as on Windows, see screenshots.

I think that on AROS 68k it is better to use a native AROS 68k system and not a Standard OS3 sustema ;)



amiga23

  • Newbie
  • *
    • Posts: 19
    • Karma: +1/-0
Reply #4 on: November 17, 2019, 09:23:30 PM
I thought the goal is to be compatible with OS3?



AMIGASYSTEM

  • Member
  • ***
    • Posts: 113
    • Karma: +2/-0
Reply #5 on: November 17, 2019, 10:54:11 PM
Native OS3 software "works" on AROS 68k, native AROS 68k software "does not work" on OS3!



wawa

  • Senior Member
  • ****
    • Posts: 252
    • Karma: +1/-0
Reply #6 on: November 18, 2019, 01:15:12 PM
@amiga23
Quote
I thought the goal is to be compatible with OS3?

it may not be possible to provide a complete and full functional compatibility for each and every application. same as many amiga applications are not compatible with each other or depend on a specific version of kickstart.

in my opinion, being able to run the genuine amiga workbench on aros is already a proof of good compatibility.

however we might be able to look into it a bit.

Quote
If an icon get's selected, an alternative icon is shown. When the icon gets deselected to original icon is show.
On AROS Workbench, the parts of the alternative icon, that are transparent in the original icon, stay visible. For example glow icons: the glow stays visible. Or folders that open and give a view inside do still show mixed with the closed folder.


i might be able to check if i can reproduce this.

afair aros icon.library is in aros ks. which means, its the active one, you are using. you might want to check library version loaded. it should be possible with some shell command, like version or an utility like scout.
to replace it with the amiga or peter k's version you would have to loadmodule it. you might want to check, if it cures the behaviour.
but the issue seems rather easy to narrow down and fix. im not a coder but ill try to look at the source and see what mmay be the cause, like memory not being cleared at some point.



wawa

  • Senior Member
  • ****
    • Posts: 252
    • Karma: +1/-0
Reply #7 on: November 18, 2019, 01:22:24 PM
@amiga23

btw you can get kickstart rom updates here:
http://aros.sourceforge.net/de/nightly1.php
the first two images should contain the files.
i hope also our m68k fork section is soon back up. ill post there a link.
because if we fix it you will have to update the kickstart files and i dont know how they are stored in vampire (v4?)

other than that i can teach you how to build aros, if you want. i consider it rather easy. but you need a linux environment to cross compile.



amiga23

  • Newbie
  • *
    • Posts: 19
    • Karma: +1/-0
Reply #8 on: November 19, 2019, 08:40:03 PM
1. Icon.library
LoadModule icon.library (46.4.518 freshly from aminet) in startup-sequene causes very bad crash with funny things on the screen.

If I boot without startup-sequence and type "loadmodule libs:icon.library" I get the message "Please turn off our system using the power switch. You may need to press the switch for up to five seconds."


2. Building AROS myself
I can offer Linux, Mac OS, Morph OS, AROS i386 and Amiga OS.
Would be great if you good point me to a guide on how to compile AROS in a VM. I am not a C Developer, but I could apply patches and add debug outputs to nail things down, would be easier than always waiting for nightly builds.


3. Using Nightly builds
Just to be sure I understand correctly. AROS for Vampire Standalone V4 (vsa-v4) is nothing special for the vampire but just the aros.hunk from "amiga-m68k-boot-floppy" ? It has 1MB, but simply renaming it to kick.rom does not work: "Cannot read KICK.ROM".



wawa

  • Senior Member
  • ****
    • Posts: 252
    • Karma: +1/-0
Reply #9 on: November 20, 2019, 07:22:17 PM
1. okay. looks like my to do list is growing. now i need to test the icon lib issues.

2. roughly the instructions here still apply:
http://aros.sourceforge.net/documentation/developers/compiling.php
please try to get the mentioned mandatory packages installed first.
down the page is how you check out/clone the sources out of the github repo.
note that you need to clone contrib source inside the AROS one if you want to compile it as well.
please dont compile/build inside the source dir. use outside dir instead and configure from there.
the configure line would then look something like:
../AROS-git/AROS/configure --target=amiga-m68k --with-serial-debug=yes --with-portssources=/home/wawa/portssources --with-binutils-version=2.32 --with-gcc-version=9.1.0

actually only target is mandatory. the other flags set newer crostools versions, debug and a local folder for fetched sources.

3. unfortunatelly i dont know how aros ks is stored on a vamp.

please ask guys from the team, gunnar or saimo, maybe you could join us on slack, in order to test more effectively, if you want.



AMIGASYSTEM

  • Member
  • ***
    • Posts: 113
    • Karma: +2/-0
Reply #10 on: November 20, 2019, 10:02:53 PM
1. Icon.library
LoadModule icon.library (46.4.518 freshly from aminet) in startup-sequene causes very bad crash with funny things on the screen.

I on AROS 68 "Standard" on WinUAE have no Crash with LoadModule icon.library (I used icon.library_TC020)

Why do you want to use the icon.library by Peter Keunecke on AROS 68k? The icon.library AROS 68k works better!



wawa

  • Senior Member
  • ****
    • Posts: 252
    • Karma: +1/-0
Reply #11 on: November 21, 2019, 01:21:11 PM
drom saimo:
https://usercontent.irccloud-cdn.com/file/PoBRtmoE/IconLib_46.4.png
loadmodule icon lib works for him.
perhaps it needs to be loaded early?



AMIGASYSTEM

  • Member
  • ***
    • Posts: 113
    • Karma: +2/-0
Reply #12 on: November 21, 2019, 07:15:47 PM
With IconLib 46.4 you can't get clean "drag" icons without graphic artifacts!



AMIGASYSTEM

  • Member
  • ***
    • Posts: 113
    • Karma: +2/-0
Reply #13 on: November 30, 2019, 07:11:03 PM
1. Icon.library
LoadModule icon.library (46.4.518 freshly from aminet) in startup-sequene causes very bad crash with funny things on the screen.

If I boot without startup-sequence and type "loadmodule libs:icon.library" I get the message "Please turn off our system using the power switch. You may need to press the switch for up to five seconds."
New icon.library "Alpha" for AROS 68k, download and information on how to use it:

http://eab.abime.net/showthread.php?t=64079&page=160