Author Topic: Porting Odyssey 1.26 from MorphOS 3.12!  (Read 1165 times)

salvo

  • Member
  • ***
  • Posts: 182
  • Karma: +0/-0
  • Invalid Civil
Re: Porting Odyssey 1.26 from MorphOS 3.12!
« Reply #45 on: October 30, 2019, 04:56:58 PM »
thank's wawa, maybe i can install icaros desktop later if you upgrading the openssl library :D
Icaros on HP Z600 Intel Xeon X5570 3 Ghz, Nvidia 8400gs
Support
https://www.actionaid.it/
https://www.amref.it/

deadwood

  • AROS Developer
  • Junior Member
  • *****
  • Posts: 54
  • Karma: +2/-0
Re: Porting Odyssey 1.26 from MorphOS 3.12!
« Reply #46 on: October 30, 2019, 06:07:41 PM »
yeah, its abi v0 for sure. just verified. even folder structure is different a bit.
now. to build odyssey with the build sys i need some modules from contrib. though im not sure if the sources are still fully compatible with v0. especially the mmakefiles.
@deadwood
what do you think? you aint hosting contrib back port by chance if it was necessary?

Unfortunatelly I don't have it available. Possibly the fastest approach for you is to disable all the contrib targets that require changed build system. If that doesn't work I might look into bringing contrib backpart back.

wawa

  • Senior Member
  • ****
  • Posts: 252
  • Karma: +1/-0
Re: Porting Odyssey 1.26 from MorphOS 3.12!
« Reply #47 on: October 30, 2019, 06:15:04 PM »
i am only invoking odyssey module make so i assume all the modules that are being triggered to build are required as dependencies even if i eventually indirectly.

salvo

  • Member
  • ***
  • Posts: 182
  • Karma: +0/-0
  • Invalid Civil
Re: Porting Odyssey 1.26 from MorphOS 3.12!
« Reply #48 on: October 30, 2019, 06:18:00 PM »
nicola scendoni did this for openssl

The compilaton was successfully tested using Ubuntu 14.04.5 LTS 32 bit. Below the list of packages installed. In order to compile you need to apply the provided patch. Here the steps I followed.

svn co --username guest --password guest https://svn.aros.org/svn/aros/branches/ABI_V0-20161228
git clone https://github.com/deadwood-pl/OdysseyWebBrowser.git
cd OdysseyWebBrowser.git
git checkout odyssey-r187682
cd ..

cd ABI_V0-20161228/AROS
mkdir local
cd local
ln -s ../../OdysseyWebBrowser.git odyssey
cd ..
ln -s ../contrib
patch -p0 -i ../OdysseyWebBrowser/ABI_V0-20161228-patch/ABI_V0-20161228.diff

../ABI_V0-20161228/AROS/configure --target=linux-i386 --with-portssources=/home/nicola/PortSources --with-paranoia=no --with-gcc-version=4.8.3 --with-binutils-version=2.25
make

make local-odyssey

ps. the patch do not working because openssl is obsolete

"Setup of VM"

Starting from a base installation of Ubuntu 14.04.5 LTS 32 bit Server execute following commands:

sudo apt update
sudo apt install -y unzip

#Packages metioned in gimmearos.sh
sudo apt install -y subversion
sudo apt install -y git-core
sudo apt install -y gcc
sudo apt install -y g++
sudo apt install -y make
sudo apt install -y gawk
sudo apt install -y bison
sudo apt install -y flex
sudo apt install -y bzip2
sudo apt install -y netpbm
sudo apt install -y autoconf
sudo apt install -y automake
sudo apt install -y libx11-dev
sudo apt install -y libxext-dev
sudo apt install -y libc6-dev
sudo apt install -y liblzo2-dev
sudo apt install -y libxxf86vm-dev
sudo apt install -y libpng12-dev
sudo apt install -y gcc-multilib
sudo apt install -y libsdl1.2-dev
sudo apt install -y byacc
sudo apt install -y cmake

#Additional requirement to compile (not mentioned in gimmearos)
apt -y install libgl1-mesa-dev xorg-dev
apt -y install cmake
apt -y install gperf
apt -y install libswitch-perl

apt -y install texinfo
apt -y install uml-utilities

apt -y install vnc4server
apt -y install ruby
apt -y install ruby-dev

#Packages required to run AROS
dpkg --add-architecture i386
apt update
apt -y install libxcursor1:i386
apt -y install libxxf86vm1:i386

#Optional: install xorg and openbox
apt -y xorg openbox

# Change X11 resolution
# xrandr --output VGA-0 --mode 1280x960
Icaros on HP Z600 Intel Xeon X5570 3 Ghz, Nvidia 8400gs
Support
https://www.actionaid.it/
https://www.amref.it/

salvo

  • Member
  • ***
  • Posts: 182
  • Karma: +0/-0
  • Invalid Civil
Re: Porting Odyssey 1.26 from MorphOS 3.12!
« Reply #49 on: October 30, 2019, 06:20:48 PM »
I couldn't finish anything :-\
Icaros on HP Z600 Intel Xeon X5570 3 Ghz, Nvidia 8400gs
Support
https://www.actionaid.it/
https://www.amref.it/

deadwood

  • AROS Developer
  • Junior Member
  • *****
  • Posts: 54
  • Karma: +2/-0
Re: Porting Odyssey 1.26 from MorphOS 3.12!
« Reply #50 on: October 30, 2019, 06:23:39 PM »
i am only invoking odyssey module make so i assume all the modules that are being triggered to build are required as dependencies even if i eventually indirectly.

The errors you are getting are happening during initial scanning. Then metamake is generating makefiles regardless if the module is needed or not.