Hosted on Windows

miker1264 · 192

miker1264

  • Senior Member
  • ****
    • Posts: 342
    • Karma: +12/-1
on: September 29, 2019, 07:27:32 PM
For programming and testing I'm abandoning Hosted on Windows in favor of Hosted on Linux and AROS Native. Hosted on Windows is very quirky! Firstly, the Snapshots don't work correctly. Secondly, and I'm sure there's more, the DataTypes System isn't working correctly either.

On Hosted on Windows when I compile and install a new version of a datatype in Sys:Classes/Datatypes and restart it should load it into the system and make it active. It doesn't. Instead it doesn't release the previous version of the datatype. It keeps using the older version.

I suspected that was the case so I deleted the dataype completely and restarted. It still worked to load and display images without the datatype!

On AROS Native however everything works as it should. When a new version of a datatype is copied to Sys:Classes/Datatypes on restart it gets loaded and becomes the active version instead.

Maybe the quirky behavior of the datatypes on Hosted on Windows is the primary reason I was struggling to display BMPX Alpha Transparency.
« Last Edit: September 29, 2019, 07:57:44 PM by miker1264 »



salvatore

  • Guest
Reply #1 on: September 29, 2019, 10:36:23 PM
the hosted linux function is interesting because it can work in full screen and have the possibility of displaying linux applications on the desktop, but I am only interested in the native version but currently with odyssey I have encountered several problems and therefore no aros and I hope you take into consideration this thing, I know that resources are at the limit ::)



miker1264

  • Senior Member
  • ****
    • Posts: 342
    • Karma: +12/-1
Reply #2 on: September 29, 2019, 11:21:53 PM
Odyssey, is it the same as OWB? I believe Deadwood was working on that for AROS.

I am looking forward to using Ubuntu Studio in Full Screen Mode and with Hostbridge. BTW salvatore, did you know that with Hosted on Linux you can launch Opera or Firefox from Hostbridge.

Unless you are only using AROS Native exclusively then you don't need Odyssey using Linux Hosted.



salvatore

  • Guest
Reply #3 on: September 29, 2019, 11:25:49 PM
I don't think that deadwood is working on it, he is working on something else, owb the first version was called orygin, I don't like the hosted solution anyway I tried with hostbridge but it doesn't work even on mint



salvatore

  • Guest
Reply #4 on: September 29, 2019, 11:26:36 PM
currently i have uninstalled aros unfortunately



miker1264

  • Senior Member
  • ****
    • Posts: 342
    • Karma: +12/-1
Reply #5 on: September 29, 2019, 11:31:39 PM
I don't think that deadwood is working on it, he is working on something else, owb the first version was called orygin, I don't like the hosted solution anyway I tried with hostbridge but it doesn't work even on mint

Host Bridge doesn't work on Linux or OWB doesn't launch correctly? If Hist Bridge works and launches Firefox on Linux would you be satisfied with that solution?

Let me install Hosted on Linux then test Host Bridge and a few other things as well.



miker1264

  • Senior Member
  • ****
    • Posts: 342
    • Karma: +12/-1
Reply #6 on: September 29, 2019, 11:32:43 PM
currently i have uninstalled aros unfortunately

Don't give up so easily! 😊



paolone

  • Moderator
  • Senior Member
  • *****
    • Posts: 295
    • Karma: +3/-0
Reply #7 on: September 30, 2019, 09:08:40 AM
For programming and testing I'm abandoning Hosted on Windows in favor of Hosted on Linux and AROS Native. Hosted on Windows is very quirky! Firstly, the Snapshots don't work correctly. Secondly, and I'm sure there's more, the DataTypes System isn't working correctly either.

On Hosted on Windows when I compile and install a new version of a datatype in Sys:Classes/Datatypes and restart it should load it into the system and make it active. It doesn't. Instead it doesn't release the previous version of the datatype. It keeps using the older version.

I suspected that was the case so I deleted the dataype completely and restarted. It still worked to load and display images without the datatype!

On AROS Native however everything works as it should. When a new version of a datatype is copied to Sys:Classes/Datatypes on restart it gets loaded and becomes the active version instead.

Maybe the quirky behavior of the datatypes on Hosted on Windows is the primary reason I was struggling to display BMPX Alpha Transparency.


This is the typical behavior when permissions on files are wrong. Have you installed Icaros using "run as administrator" somewhere? Please don't.


Anyway, Linux hosted Icaros is FAR better shaped.- For development, please use this instead of the Windows one. The best fitting combo on Windows is native version installed on a vmware virtual machine.
« Last Edit: September 30, 2019, 10:03:01 AM by paolone »



paolone

  • Moderator
  • Senior Member
  • *****
    • Posts: 295
    • Karma: +3/-0
Reply #8 on: September 30, 2019, 09:22:27 AM
I don't think that deadwood is working on it, he is working on something else, owb the first version was called orygin, I don't like the hosted solution anyway I tried with hostbridge but it doesn't work even on mint


"it does not work" is kind of different from "I am not good at it" ;-)


salvatore

  • Guest
Reply #9 on: September 30, 2019, 12:34:40 PM
I don't even answer you "ok", but I have no intention of using the hosted version ;)