Compile Odyssey for ABI_V0

ch1ll · 5715

salvatore

  • Guest
Reply #105 on: June 08, 2019, 12:05:18 PM
thank you very much guys



lm

  • Guest
Reply #106 on: June 09, 2019, 11:07:42 AM
@ ch1ll :

Can you tell us what are you doing with Odyssey right now ?



ch1ll

  • Newbie
  • *
    • Posts: 31
    • Karma: +0/-0
Reply #107 on: June 09, 2019, 09:11:27 PM
Quote

I updated the patch for ABIv0 GCC 6.1.0 to support the -newclib flag:
https://ae.amigalife.org/index.php?topic=60.msg1381#msg1381
With this I was able to compile the AROS with it without poking the configure files.

Thank you very much! It works  :)



ch1ll

  • Newbie
  • *
    • Posts: 31
    • Karma: +0/-0
Reply #108 on: June 09, 2019, 09:23:03 PM
@ ch1ll :

Can you tell us what are you doing with Odyssey right now ?

As of now I rebuilt my dev environment and cleaned up my fixes.
Then I need to find an efficient way to debug... as of now the link of owb with debug symbols fails.

@nikos: I just restarted the work on Odyssey...



salvatore

  • Guest
Reply #109 on: June 09, 2019, 09:36:39 PM
great ch1ll  :D



deadwood

  • AROS Developer
  • Junior Member
  • *****
    • Posts: 55
    • Karma: +2/-0
Reply #110 on: June 09, 2019, 09:47:36 PM

Then I need to find an efficient way to debug... as of now the link of owb with debug symbols fails.


I was never sucesfull with this. The debug binary is about 650MB in size and it failed to load under linux-hosted. The only way to debug was via printing messages via bug().



salvatore

  • Guest
Reply #111 on: June 09, 2019, 10:01:02 PM
hopefully well, but it seems to me that the most work is on ffmpeg



salvatore

  • Guest
Reply #112 on: June 10, 2019, 10:44:37 PM
surely having the browser and view the pages without artifacts is something else, I was really getting tired ;)



salvo

  • Member
  • ***
    • Posts: 200
    • Karma: +0/-0
  • Invalid Civil
Reply #113 on: October 02, 2019, 05:32:21 PM
ebay and facebook don't show image item/post, maybe there is the problem with ssl library

Best

Icaros on HP Z600 Intel Xeon X5570 3 Ghz, Nvidia 8400gs
Support
https://www.actionaid.it/
https://www.amref.it/