Author Topic: Compile Odyssey for ABI_V0  (Read 4555 times)

sabbate

  • Guest
Re: Compile Odyssey for ABI_V0
« Reply #75 on: December 09, 2018, 04:14:31 PM »
I thought I could use this version of owb with icaros 1.4 is the only part of my computer imho, however with a pentium 4 I should go on the safe side, I will spend another 20 euros

hi

Salvatore

paolone

  • Member
  • ***
  • Posts: 196
  • Karma: +3/-0
Re: Compile Odyssey for ABI_V0
« Reply #76 on: December 10, 2018, 04:06:44 PM »
I downloaded icaros desktop light 1.4 everything works perfectly, when I have time I try the last of the 1.x series, I will update what I need, like the fat handler etc..etc ..
Hi. The 1.x series has been deprecated for years. Too much old AROS code, and some applications *need* at least Icaros 2.0 to work.

sabbate

  • Guest
Re: Compile Odyssey for ABI_V0
« Reply #77 on: December 10, 2018, 06:29:32 PM »
Yes Paolone i verified :)

ch1ll

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
Re: Compile Odyssey for ABI_V0
« Reply #78 on: December 11, 2018, 09:25:17 PM »
Hi. I'll start with a big thank you, since your build of OWB seems also more stable (at least, this is the feeling I have today with current websites). The only issue I have is that its executable is around 100 MB bigger, and does not fit at all in Icaros Desktop Light. Is there any plan to shrink/strip it down, maybe using some development magic I am totally unaware of?

You can find a new version without debugging symbols on this link: https://drive.google.com/open?id=1D_e0EXa7IYyix5GBhGYsmTqQpvn67iA-
I did not ffmpeg 3.0.1, since I found why it was crashing every time. There is a bug in AROS ABI_V0 on the posix function posix_memalign. I modified the code to not use it.
Please let me know how is it...

nikos

  • Member
  • ***
  • Posts: 185
  • Karma: +2/-1
    • aspireos
Re: Compile Odyssey for ABI_V0
« Reply #79 on: December 12, 2018, 12:56:05 AM »
Thanks. There is something real good that happend with your new version. It is very fast!! :)
Video does not crash anymore but got playback error trying to play.

This is what I got from youtube.

An error occurred. Please try again later. (Playback ID: ZF-olCE815RfzoSj)
Learn More

« Last Edit: December 12, 2018, 01:25:46 AM by nikos »

ch1ll

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
Re: Compile Odyssey for ABI_V0
« Reply #80 on: December 12, 2018, 11:02:31 PM »
I also have that error with youtube. This is compiled with the version 3.0.1 of ffmpeg with the old integration code.
Do you have the same error also with the previous version compiled by deadwood?

nikos

  • Member
  • ***
  • Posts: 185
  • Karma: +2/-1
    • aspireos
Re: Compile Odyssey for ABI_V0
« Reply #81 on: December 12, 2018, 11:43:59 PM »
The old version from Deadwood youtube works, but as you know there are some issues with the playback.
 

nikos

  • Member
  • ***
  • Posts: 185
  • Karma: +2/-1
    • aspireos
Re: Compile Odyssey for ABI_V0
« Reply #82 on: December 13, 2018, 09:02:01 PM »
I also have that error with youtube. This is compiled with the version 3.0.1 of ffmpeg with the old integration code.
Do you have the same error also with the previous version compiled by deadwood?

Neil will try to fix posix_memalign. Lets hope it is related to the video problem. He will not test it in Odyssey, but guess you can do  that ch1||.
I keep you posted.

ch1ll

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
Re: Compile Odyssey for ABI_V0
« Reply #83 on: December 13, 2018, 09:35:37 PM »
I would be cool to have the fix for posix_memalign, but I guess the issue we are facing with youtube is something else...somebody knows what version of ffmpeg was used by deadwoood?

I would not like to spend much time to debug ffmpeg3.0.1, but I'm working to make it work with ffmpeg 4.0.1...

sabbate

  • Guest
Re: Compile Odyssey for ABI_V0
« Reply #84 on: December 17, 2018, 07:56:50 AM »
I can not get into a site (imusician/login) I do not know if it's a ssl or engine protocol problem

hi

Salvatore

sabbate

  • Guest
Re: Compile Odyssey for ABI_V0
« Reply #85 on: December 17, 2018, 11:10:12 AM »
if I identify myself as opera 12 everything is fine, thanks for everything nicola

hi

Salvatore

aha

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
Re: Compile Odyssey for ABI_V0
« Reply #86 on: December 20, 2018, 12:04:01 PM »
Quote
Neil will try to fix posix_memalign.

Very appreciated! :D I am looking forward to the fix. Thank you for your efforts, Neil!

nikos

  • Member
  • ***
  • Posts: 185
  • Karma: +2/-1
    • aspireos
Re: Compile Odyssey for ABI_V0
« Reply #87 on: January 06, 2019, 07:24:04 PM »
To get the streaming working at least with youtube would make our system so more usefull.
The latest compile of Odyssey with new SSL is very nice. Fast and quite stable. Not that many pages not working. I would say at least 80% works as in any other browser.

I'm thinking if it is possible to make a post at amigaworld and point to the source code where the video stuff are. There are many talented developers looking in forums that could at least come up with some ideas of what is the reason for this. Also some good explenations about what happen trying to play video are important.

If Ch 1|| can get new ffmpeg working with Odyssey it might solve the problem. I'm not sure what ffmpeg version MorphOS use.

First of all this should be a straigh port from MorphOS version where Video does work.
What I know about MorphOS is that they have overlay and we don't. That should not have
anything to do with it I guess.
« Last Edit: January 06, 2019, 07:32:27 PM by nikos »

aha

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
Re: Compile Odyssey for ABI_V0
« Reply #88 on: February 05, 2019, 12:06:59 PM »
Quote
Neil will try to fix posix_memalign.

Very appreciated! :D I am looking forward to the fix. Thank you for your efforts, Neil!

Is this already fixed? I am just curious. :)

terminills

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
Re: Compile Odyssey for ABI_V0
« Reply #89 on: February 05, 2019, 02:08:36 PM »
First of all this should be a straigh port from MorphOS version where Video does work.
What I know about MorphOS is that they have overlay and we don't. That should not have
anything to do with it I guess.


Not quite.   The embedded video player did not come from MorphOS iirc.