Author Topic: X11 bug on Linux Hosted Install  (Read 219 times)

Demerzel the Eternal

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
X11 bug on Linux Hosted Install
« on: February 14, 2019, 02:18:07 PM »
Has anyone come across this before, I'm using a Macbook with Linux Mint and decided to have Icaros hosted, all went well but on first boot I got:

[Bootstrap] Entering kernel at 0xb7a35000...
[X11host] x11_hostlib_load_so: failed to open 'libXcursor.so.1': libXcursor.so.1: cannot open shared object file: No such file or directory
[I2C] Init
[ATI] Init
Display driver(s) failed to initialize. Entering emergency shell.
EndCLI will quit AROS.

Any Ideas peeps, its driving me mad.
BTW ICAROS installs native on my MacBook so it is compatible.

Thanks in advance for any advice

dizzy

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: X11 bug on Linux Hosted Install
« Reply #1 on: February 14, 2019, 03:37:38 PM »
It's the Wayland, AROS doesn't seem to like it. Log on using something else if possible or use SDL driver

Overcast451

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: X11 bug on Linux Hosted Install
« Reply #2 on: March 09, 2019, 07:06:30 AM »
If it's any help, I had to disable wayland on my PC for the nVidia driver to work.

/etc/gdm/custom.conf
There's a line in there you uncomment to disable wayland, at least on Fedora 29 / x64. I'm not sure how that might impact your system, however..

AROS runs pretty well under Fed29, using free VMWare Player 15 to run it. I did have to lock my resolution in to 1440 x 900 to make it fit ok. I just set the VM's max resolution to that.

wawa

  • Junior Member
  • **
  • Posts: 88
  • Karma: +0/-0
Re: X11 bug on Linux Hosted Install
« Reply #3 on: March 09, 2019, 02:22:37 PM »
the issue is clearly visible in the log. simply install the packages containing the missing shared objects.

dizzy

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: X11 bug on Linux Hosted Install
« Reply #4 on: March 09, 2019, 07:14:39 PM »
The problem is not missing libs but simply Wayland. On Fedora one can choose when logging if to use it or not.