Author Topic: Icaros Desktop Sound Speed Issues! SOLVED  (Read 276 times)

aurabin

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • aurabin.net
Icaros Desktop Sound Speed Issues! SOLVED
« on: October 17, 2018, 08:24:58 PM »
I made a Video of Icaros Desktop running on VM Ware on Windows 10 Pro 64 Bit showing some Sound Speed Issues.. Sound is overall too slow!

https://www.youtube.com/watch?v=EVt-Ydpn-MI
« Last Edit: October 21, 2018, 06:56:14 PM by aurabin »

paolone

  • Moderator
  • Junior Member
  • *****
  • Posts: 68
    • View Profile
Re: Icaros Desktop Sound Speed Issues!
« Reply #1 on: October 18, 2018, 10:04:14 AM »
I've answered to you on the youtube page.

aurabin

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • aurabin.net
Re: Icaros Desktop Sound Speed Issues! SOLVED
« Reply #2 on: October 21, 2018, 06:57:44 PM »
I tweaked a little with Janus UAE 1.4 and VICE 3.1 C=64 Emulator and managed to solve the Sound Problems!

Watch here:

https://youtu.be/jYyy0u14SSo

paolone

  • Moderator
  • Junior Member
  • *****
  • Posts: 68
    • View Profile
Re: Icaros Desktop Sound Speed Issues! SOLVED
« Reply #3 on: October 22, 2018, 11:39:15 AM »
Great.

paolone

  • Moderator
  • Junior Member
  • *****
  • Posts: 68
    • View Profile
Re: Icaros Desktop Sound Speed Issues! SOLVED
« Reply #4 on: October 22, 2018, 01:38:44 PM »
I studied your solution. I have fixed Icaros VICE settings according to your video or almost, however I can't do the same for Janus-UAE.
Disabling the idle thing on the emulated processor kills AROS host speed. In the ideal Icaros world, the user should be able to use both M68K and i386 programs concurrently, so I have to reserve CPU resources for both. Disabling the idle on STOP instruction option gives Janus-UAE the maximun priority over any other task running on the host side.
However, a mechanism that would give an app different settings already exists: you can create a shortcut in the AmiBridge menu. Please try with EaglePlayer. Once you are running EaglePlayer only through its shortcut, press lAros+Tab to switch to x86 side, open the Janus GUI, disable "idle on stop" option and save. This setting will be tied to EaglePlayer only.