AROS ABIv0 20201110 Development

deadwood · 2309

deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1233
    • Karma: +110/-0
on: January 07, 2023, 07:20:55 PM
Hello,

Time to start next release iteration. The goal is to upgrade to base of 20200413 20201110. It will be done in a few iterations updating around 2 months at a time. I plan to discover bugs in these iteration and fix them once we get to final base. You should consider any of -Dx releases as non-production - I have not checked backward compatibility with them.

First, reference ISO:

Native
Referencehttps://www.axrt.org/download/aros/v0/AROS-20190416-2-pc-i386-boot-iso.zip

First iteration moves us to 20190429 code base. It only a "couple of days" compared to reference, but it includes changes that I had to revert to previous state.

https://axrt.org/development/AROS-20190429-D1-pc-i386-boot-iso.zip

The key in this first iteration is to re-test 2D and 3D capabilities of IntelGMA and Nouveau drivers as compared to reference release. Testing if software 3D rendering has no regression compared to reference would also be welcomed.


Here is change log:
Code: [Select]
AROS ABIv0 20190429 changes:

  Functionalities:
    Display free video memory in SysMon where supported (Kalamatee)
    Initial work on supporting 3D acceleration in VMWare video driver (Kalamatee)

  64-bit support:


  68k support:


  ARM support:


  Updates:
    AROS build system (Kalamatee)
    Polish catalogs for SysExplorer, SysMon (wawa)

  Functional fixes:
    Prefs/ScreenMode (Kalamatee)

  Stability fixes:
« Last Edit: January 24, 2023, 04:20:30 PM by deadwood »



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #1 on: January 07, 2023, 09:46:55 PM
Tested "20200413" on WMware, now with AROS x86 you can use a native Graphics Card, but I only get SVGA resolution, 3D is not fast, tested some games and they are as slow as VESA


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1233
    • Karma: +110/-0
Reply #2 on: January 07, 2023, 10:25:16 PM
@AMIGASYSTEM

Thanks, good to know native work under VMWare. 3D indeed is disabled for VMWare driver at the moment, so it uses software rendering. Are you able to test either IntelGMA or NVidia cards?



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #3 on: January 07, 2023, 11:05:19 PM
Successfully tested "Intel GMA 950" on ACER Aspire One ZG5 and Dell Inspiron Mini 910, see screenshot

I do not have a supported NVIDEA Video Card
 
I have an ACER ASpire 5920 with a NVIDIA GeForce 8600M GT not supported "Black Screen"

Question that has nothing to do with video cards, I noticed that some 3D games have automatic fire, this may depend on AROS or ACER Aspire One ZG5 and Dell Inspiron Mini 910 laptops

I now integrate "20200413" on AROS One and text some Third Party Application

« Last Edit: January 07, 2023, 11:09:24 PM by AMIGASYSTEM »



ncafferkey

  • Junior Member
  • **
    • Posts: 58
    • Karma: +21/-0
Reply #4 on: January 07, 2023, 11:34:12 PM
My tests so far...

VirtualBox 6.1.34:

 - Both ISOs boot. I then installed each to USB sticks from there successfully.

Dell Inspiron 6400 (GMA graphics):

 - Both ISOs boot in VESA and native graphics modes.
 - Mesa demo "gears" works in both graphics modes, but crashes on exit on 2019-04-29 native mode only.
 - Screenmode switching in native works on both ISOs, but I had one unreproduceable guru (I think this was with 2019-04-16 but I'm not sure).

Acer AspireOne ZG5 A110 (GMA graphics):

 - Neither ISO boots in either graphics mode. I usually don't see an error, just a reboot, but once I saw "Priviledge Violation" in a guru window briefly. @AMIGASYSTEM: what's the exact model and spec of your ZG5?
 - It boots with 2019-03-09 *ABIv1*. I'm currently making a 2019-01-21 ABIv0 USB stick to test with (the previous nightly I happen to have). EDIT: 2019-01-21 boots.
« Last Edit: January 08, 2023, 02:32:59 AM by ncafferkey »



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #5 on: January 08, 2023, 01:10:08 AM
I don't have the documentation of the Aspire One ZG5, it was given to me as a gift, I attach the label although there is not much information.

If it helps the model is THIS, should be Acer Aspire One ZG5 AOA 110 white SD 8GB welded dead :(

I have never tested AROS ABIv1 versions, I could try if needed !


Tests on VM I did with WMWare Player 7.1.2 build-2780323
« Last Edit: January 08, 2023, 01:28:12 AM by AMIGASYSTEM »



ncafferkey

  • Junior Member
  • **
    • Posts: 58
    • Karma: +21/-0
Reply #6 on: January 08, 2023, 02:23:47 AM
@AMIGASYSTEM: Thanks, my label is identical. It seems our ZG5s are the same, so the difference in behaviour is strange. Unless the dead SSD allows it to work  :D



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1233
    • Karma: +110/-0
Reply #7 on: January 08, 2023, 07:25:58 AM
Successfully tested "Intel GMA 950" on ACER Aspire One ZG5 and Dell Inspiron Mini 910, see screenshot

Thanks!



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1233
    • Karma: +110/-0
Reply #8 on: January 08, 2023, 07:28:05 AM

Dell Inspiron 6400 (GMA graphics):

 - Mesa demo "gears" works in both graphics modes, but crashes on exit on 2019-04-29 native mode only.

Is this is hard crash (=reset) or are you able to capture the backtrace from Guru requester?

Acer AspireOne ZG5 A110 (GMA graphics):

 - Neither ISO boots in either graphics mode. I usually don't see an error, just a reboot, but once I saw "Priviledge Violation" in a guru window briefly. @AMIGASYSTEM: what's the exact model and spec of your ZG5?
 - It boots with 2019-03-09 *ABIv1*. I'm currently making a 2019-01-21 ABIv0 USB stick to test with (the previous nightly I happen to have). EDIT: 2019-01-21 boots.

The 2019-01-21 is build based on SVN, right?



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #9 on: January 08, 2023, 10:14:55 AM
@AMIGASYSTEM: Thanks, my label is identical. It seems our ZG5s are the same, so the difference in behaviour is strange. Unless the dead SSD allows it to work  :D

I don't think it is the SD that does the miracle, even my little "Dell Inspiron Mini 910" which seems to have an Identical Video Card has no problem, see attached video made 1 year ago.

https://youtu.be/bOU5gSdkKdA


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1233
    • Karma: +110/-0
Reply #10 on: January 08, 2023, 10:28:24 AM
@AMIGASYSTEM: Thanks, my label is identical. It seems our ZG5s are the same, so the difference in behaviour is strange. Unless the dead SSD allows it to work  :D

Maybe it's down to default settings in BIOS for disk chipsets: IDE vs SATA. I believe we need to always revert to IDE on that setting, because out sata driver still has problems sometimes.



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #11 on: January 08, 2023, 11:21:57 AM
My "Dell Inspiron Mini 910" does not have a Hardisk but an SD Card PATA 8GB with Window XP Installed !


AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #12 on: January 08, 2023, 11:39:25 AM
By integrating "20200413" on AROS One x86 on "WMWare SVGA", I had encountered the same problem of corrupted icon graphics as as with Scalos (see screenshot), as if by magic the problem is solved by reconfiguring from scratch Wanderer Prefs :)


AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2637
    • Karma: +64/-1
  • AROS One
    • AROS One
Reply #13 on: January 08, 2023, 12:49:12 PM
By integrating "20200413" on AROS One x86 on "WMWare SVGA", I had encountered the same problem of corrupted icon graphics as as with Scalos (see screenshot), as if by magic the problem is solved by reconfiguring from scratch Wanderer Prefs :)

Uncovered the arcane, what created the graphic corruption of the icons was the "Floating" option in Wanderer prefs, you re-solve the problem by using the "Fixed" option


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1233
    • Karma: +110/-0
Reply #14 on: January 08, 2023, 03:54:41 PM
Added bug report: https://github.com/deadw00d/AROS/issues/85

Since there is a workaround, I won't be looking into this right now.