Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Development (General) / Re: ABI V1
« Last post by cdimauro on February 21, 2019, 10:31:50 AM »
Is there any (updated) document which reports the ABI v1 status?
22
Development (General) / Re: ABI V1
« Last post by o1i on February 21, 2019, 10:06:04 AM »
To be honest, I simply would declare the AB! v1 project done. 

I would dump 32bit x86 completely, nobody needs this anymore and declare v1/64bit x86 as completed. There might be issues left (most likely there are), but if really necessary, those should be fixed in ABI v2..

ARM/m68k are v1 anyways already..
23
Development (General) / Re: ABI V1
« Last post by cavemann on February 21, 2019, 03:06:21 AM »
Yes there's activity, and there has been activity for years. But in terms of the original question, an updated gcc won't make the transition happen anytime soon. There's also libs and drivers that need to be done, not to mention the ABI itself.

In the mean time, perhaps we should focus on other things, radeon drivers? sata handlers? python? etc, etc, etc.
24
General Chat / Re: General fund
« Last post by terminills on February 20, 2019, 05:06:56 PM »
I would lose
projects should not be overly complex

It doesn't gain anything, just creates a point that may be argued about (level of complexity)

Ok thanks for the input.
25
General Chat / Re: General fund
« Last post by Troopy on February 20, 2019, 02:58:13 PM »
I would lose
projects should not be overly complex

It doesn't gain anything, just creates a point that may be argued about (level of complexity)
26
Help / Booting problems
« Last post by kipe on February 20, 2019, 01:00:56 PM »
Hi all, new here!

Iím trying to boot from i386 installation disk but it giving me errors. I put photo from screen to explain. I have Asrock N68C-S motherboard and wiki says that itís somewhat supported. But its giving errors.

https://flic.kr/p/R5AcR8



I tested and installed Icaros on another motherboard but network didnít work and have problems with sound too. So I changed this Asrock motherboard and it didnít boot to Icaros, just black screen.

I would like to get Aros working. Thank for help.
27
Development (General) / Re: ABI V1
« Last post by terminills on February 20, 2019, 01:00:48 PM »
Not much is happening.  Aros development is almost only happening with the arm port. It is our last chance the way I see it.  At least we have a stable and good abi v.0 version for i386 that is fun to play with. 68k aros is abi v.1 and is also little interesting. Vampire etc.


There's been plenty happening.   Build system updates,  Application fixes,  Subsystem fixes/enhancements.   Just because you don't see it doesn't mean it's not happening.
28
Development (General) / Re: ABI V1
« Last post by nikos on February 20, 2019, 10:12:56 AM »
Not much is happening.  Aros development is almost only happening with the arm port. It is our last chance the way I see it.  At least we have a stable and good abi v.0 version for i386 that is fun to play with. 68k aros is abi v.1 and is also little interesting. Vampire etc.
29
Development (General) / Re: ABI V1
« Last post by trekiej on February 20, 2019, 04:22:55 AM »
I am curios too.
30
General Chat / Re: Long Live The Aros
« Last post by trekiej on February 20, 2019, 01:52:44 AM »
I hope it would mean that they would work with A-eon and Hyperion.
Amiga OS4.X is not needed for making PPC motherboards and OS4.X could be developed without Amiga 68K, I believe.
I am not for sure about OS 3.1.4.
Pages: 1 2 [3] 4 5 ... 10