AROS ABIv0 20180423 Development

deadwood · 3243

AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2073
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #90 on: May 24, 2022, 02:50:01 PM
Can you check other Hollywood applications if they also show issues like these?

Yes deadwood, the problem is also present on RNOArchive and I believe in all Hollywood applications that show a list of files !


amigamia

  • Junior Member
  • **
    • Posts: 98
    • Karma: +45/-0
    • AROS World
Reply #91 on: May 24, 2022, 10:27:18 PM
Ok I'll wait and then deploy, these are all the updates done on AROS One x86 v1.7




Hi AMIGASYSTEM, where did you find - GCC v6.3.0.? I downloaded deadwood ISO but it doesn't have it.


AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2073
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #92 on: May 24, 2022, 10:50:06 PM
It is found in the Deadwood ISO "D2"


amigamia

  • Junior Member
  • **
    • Posts: 98
    • Karma: +45/-0
    • AROS World
Reply #93 on: May 24, 2022, 11:11:40 PM
Thank you! I did find it on D2 but it isn't included in the D3. I thought I was losing my mind



paolone

  • Senior Member
  • ****
    • Posts: 499
    • Karma: +87/-0
Reply #94 on: May 25, 2022, 08:53:40 AM
Ok, noted the ZunePaint window title problem for investigation.

For the requester, I created enhancement report: https://github.com/deadw00d/AROS/issues/71

As for the size, how much bigger you need. Remember that you also need to take into account m68k build where space is limited in lower resolutions. Best if you provide two sets of sizes, one for x86 another for m68k.


Wouldn't be better if requesters really followed Prefs/ReqTools settings? I changed file requester behavior with the preferences tool, setting it to appear next to mouse pointer and showing minimum 20 lines instead of 10, but guess what? Requesters still appear at the centre of the screen showing just 10 lines, so my nettings get igonored.
I even tried deleting reqtools.prefs both in env: and envarc: saving them again. No luck.

I guess this is a long standing bug. Anyway, surely it's present in D3 build.


thank you so much for your hard work on it.
« Last Edit: May 25, 2022, 09:00:16 AM by paolone »



paolone

  • Senior Member
  • ****
    • Posts: 499
    • Karma: +87/-0
Reply #95 on: May 25, 2022, 08:57:40 AM
let me know if it works OK for you, and if you find any unresponsive/incompatible 3rd party application.
You'll have to install it onto hard drive to test it thoroughly.


After integrating D3 system files in icaros desktop, i cannot warm reset AROS anymore, every time I try toi do this (or AROS itself does this, following a error), the restart gets stuck somewhere and I don't know how to make a proper bug reporting, since I guess taking logs inside AROS wouldn't make big sense.


Is it possible to make AROS do a cold reboot, instead of a warm one, when a system error occurs and user chooses to reboot the machine?


By the way, powering off through ACPI now works correctly, thank you: it didn't with last year's effort.


AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2073
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #96 on: May 25, 2022, 11:51:13 AM
Paolo to cold reboot you could use the command "Reboot", there is also "Shutdown" but it doesn't work as it should, it only comes out of AROS !
« Last Edit: May 25, 2022, 12:38:14 PM by AMIGASYSTEM »



salvo

  • Legendary Member
  • *****
    • Posts: 1881
    • Karma: +22/-4
  • Peace an Love
Reply #97 on: May 25, 2022, 12:03:06 PM
It is a problem that Deadwood already knows

IcarosDesktop on HP Z400 Workstation


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1053
    • Karma: +104/-0
Reply #98 on: May 26, 2022, 08:28:43 AM

Wouldn't be better if requesters really followed Prefs/ReqTools settings? I changed file requester behavior with the preferences tool, setting it to appear next to mouse pointer and showing minimum 20 lines instead of 10, but guess what? Requesters still appear at the centre of the screen showing just 10 lines, so my nettings get igonored.
I even tried deleting reqtools.prefs both in env: and envarc: saving them again. No luck.


That sounds like a better solution. I created a bug report for it here: https://github.com/deadw00d/AROS/issues/73



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1053
    • Karma: +104/-0
Reply #99 on: May 26, 2022, 08:31:45 AM

After integrating D3 system files in icaros desktop, i cannot warm reset AROS anymore,

By the way, powering off through ACPI now works correctly, thank you: it didn't with last year's effort.

Is this in real hardware or VM?



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2073
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #100 on: May 26, 2022, 09:34:53 AM

That sounds like a better solution. I created a bug report for it here: https://github.com/deadw00d/AROS/issues/73

I should add that the ReqTools Prefs does not save the changed values (right side of the GUI), while it allows you to add some ticks (left side of the GUI) but I do not notice any difference once they are ticked.


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1053
    • Karma: +104/-0
Reply #101 on: May 26, 2022, 06:55:23 PM
Deadwood RnoTunes have the problem with new muimaster.library the list of songs selects itself with movement of the mouse

I checked the 20180415 and 20170402 release and the problem with auto-selecting list items when moving after double-click is present there as well. It might be a bug in the program itself. I will investigate this further though. New bug that I spot is that "play" button does not seem to work correctly under 20180423. I will look into this as well.



salvo

  • Legendary Member
  • *****
    • Posts: 1881
    • Karma: +22/-4
  • Peace an Love
Reply #102 on: May 26, 2022, 08:18:03 PM
With this version of muimaster.library the program works, it seems to me that you have released it in some thread

https://jmp.sh/VTS6qt8

IcarosDesktop on HP Z400 Workstation


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1053
    • Karma: +104/-0
Reply #103 on: May 26, 2022, 08:34:51 PM
With this version of muimaster.library the program works, it seems to me that you have released it in some thread

https://jmp.sh/VTS6qt8

I was reffering to RNOTunes problem, not to ZunePaint problem :)



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2073
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #104 on: May 26, 2022, 10:16:26 PM
@deadwood

The muimaster.library posted by Salvo, is an old library from 2018, with that library everything works fine, RNOTunes and RNOArchive work fine, but ZunePaint also works fine.