New driver for 100 Mbit Broadcom Ethernet

ncafferkey · 1008

ncafferkey

  • Newbie
  • *
    • Posts: 25
    • Karma: +6/-0
on: November 27, 2021, 12:03:37 AM
Hi,

I'm dipping my toes in AROS development again, and I've written a new network driver, for the Broadcom 44xx chipset. I'm going to try to attach a test release here (x86 ABIv0).

I know this isn't the most common Ethernet chipset out there and is pretty old, but if you have the right hardware, please give it a try and report how it worked.



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2076
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #1 on: November 27, 2021, 12:16:33 AM
Hello ncafferkey and welcome back to the wonderful world AROS


miker1264

  • Legendary Member
  • *****
    • Posts: 1287
    • Karma: +82/-2
Reply #2 on: November 27, 2021, 04:18:04 AM
Hi,

I'm dipping my toes in AROS development again, and I've written a new network driver, for the Broadcom 44xx chipset. I'm going to try to attach a test release here (x86 ABIv0).

I know this isn't the most common Ethernet chipset out there and is pretty old, but if you have the right hardware, please give it a try and report how it worked.

@ncafferkey

Welcome back to AROS. I've been working steadily on several new Datatypes. Now MultiView can Save As IFF.

I added Save ILBM code to Picture Datatype to DTM_Write. I also finished the Save Functions for Targa and PCX.

MultiView can now also Save As IFF for Sound Files as well.

There are several people here who would be willing to test your new drivers.  :)



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1053
    • Karma: +104/-0
Reply #3 on: November 27, 2021, 08:00:13 AM
@ncafferkey

Hope you find enjoyment in AROS development again.



Jeff1138

  • Newbie
  • *
    • Posts: 14
    • Karma: +0/-0
Reply #4 on: November 27, 2021, 08:14:34 AM
Hi,

Welcome back, works on Dell 120L (1300 inspiron rebrand) on Aspire Xenon (i know its old)

Will try more up to date one Aros One 1.5 when I find out why the usb boot gets stuck on the second stage "waiting for bootable media"

Regards
Jeff
« Last Edit: November 27, 2021, 09:01:19 AM by Jeff1138 »



OlafS3

  • Senior Member
  • ****
    • Posts: 455
    • Karma: +47/-0
Reply #5 on: November 27, 2021, 09:47:25 AM
Hi,

I'm dipping my toes in AROS development again, and I've written a new network driver, for the Broadcom 44xx chipset. I'm going to try to attach a test release here (x86 ABIv0).

I know this isn't the most common Ethernet chipset out there and is pretty old, but if you have the right hardware, please give it a try and report how it worked.

Welcome back



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2076
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #6 on: November 27, 2021, 10:54:04 AM

Will try more up to date one Aros One 1.5 when I find out why the usb boot gets stuck on the second stage "waiting for bootable media"

The most updated version of AROS One x86 is 1.6, you can find it in the attached link, let me know if you encounter any problem

https://ae.amigalife.org/index.php?topic=773.0


salvo

  • Legendary Member
  • *****
    • Posts: 1881
    • Karma: +22/-4
  • Peace an Love
Reply #7 on: November 27, 2021, 11:03:45 AM
You are welcome again :)
« Last Edit: November 27, 2021, 11:18:39 AM by salvo »

IcarosDesktop on HP Z400 Workstation


ncafferkey

  • Newbie
  • *
    • Posts: 25
    • Karma: +6/-0
Reply #8 on: November 27, 2021, 09:34:12 PM

Welcome back, works on Dell 120L (1300 inspiron rebrand) on Aspire Xenon (i know its old)

Will try more up to date one Aros One 1.5 when I find out why the usb boot gets stuck on the second stage "waiting for bootable media"


Thanks Jeff for testing, and also thanks to you and everyone else for the welcome back.

If USB boot gets stuck on that screen it usually means AROS doesn't see the USB port (only GRUB needs to see the port for it to get that far).



Jeff1138

  • Newbie
  • *
    • Posts: 14
    • Karma: +0/-0
Reply #9 on: November 28, 2021, 07:51:42 AM
Hi,

Thanks, looks like most 32bit single core x86 ones like the machine tested get so far and then halt waiting for boot media. This is for the usb version of Aros One 1.5 and 1.6, not a problem as I prefer the usb method now for all newer hardware. But was interesting to discover and will try to get around it.

Jeff
« Last Edit: November 29, 2021, 07:43:27 AM by Jeff1138 »



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2076
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #10 on: November 30, 2021, 10:50:02 AM
This is for the usb version of Aros One 1.5 and 1.6, not a problem as I prefer the usb method now for all newer hardware. But was interesting to discover and will try to get around it.
Jeff

To verify that it is not a USB problem try burning the ISO and using a DVD !


paolone

  • Legendary Member
  • *****
    • Posts: 500
    • Karma: +87/-0
Reply #11 on: November 30, 2021, 11:48:42 AM
Hi,

I'm dipping my toes in AROS development again, and I've written a new network driver, for the Broadcom 44xx chipset. I'm going to try to attach a test release here (x86 ABIv0).

I know this isn't the most common Ethernet chipset out there and is pretty old, but if you have the right hardware, please give it a try and report how it worked.


Neil, my heart warms at seeing you back to AROS. Thanks for the effort, new hardware drivers are always a useful and welcome addition.


Jeff1138

  • Newbie
  • *
    • Posts: 14
    • Karma: +0/-0
Reply #12 on: December 04, 2021, 08:12:14 AM
Hi,

Tried Deadwoods 2021 cd and AROS 1.6 ISO burnt to discs and all boot, install and startup after a reboot.

It seems AROS one 1.6 and 1.5 USB boot will not work with Pentium M laptop GMA 900/915 until Core Duo GMA945/950 where the usb does work (do not have any Core Solos). So only can assume Intel tweaked usb between the two platform stages. Obviously, could be the laptop I have but interesting anyway just in case others have the same issue.

Could be a BIOS firmware version issue but not opening that can of worms. Hate low level updates due to bricking experience before.

Still prefer the ready made USB one where it will work but not taking this any further

Broadcom driver still working

Regards
Jeff


« Last Edit: December 04, 2021, 08:21:34 AM by Jeff1138 »



dizzy

  • Junior Member
  • **
    • Posts: 55
    • Karma: +60/-0
    • YouTube channel
Reply #13 on: December 04, 2021, 08:29:30 AM
VIA chipset for usb were buggy. Do you have such a board?



Jeff1138

  • Newbie
  • *
    • Posts: 14
    • Karma: +0/-0
Reply #14 on: December 04, 2021, 10:25:58 AM
Hi,

Welcome back as well?

Threw all the via stuff out, strange this is Intel but could be a bios issue, intel hardware bug, etc

Not sure if it worth any more time unless others suffer the same fate, way to avoid this, choose laptops with GMA945 / 950 chipsets and are able to use the great time saving usb version

Regards
Jeff
« Last Edit: December 04, 2021, 11:34:13 AM by Jeff1138 »