Refreshed m68k and x86_64 builds

deadwood · 789

OlafS3

  • Senior Member
  • ****
    • Posts: 455
    • Karma: +47/-0
Reply #15 on: June 26, 2022, 05:36:43 PM
I have updated my magellan distribution. It boots and all software seems to work. I am not sure if reqtools prefs really work or not. Do the programs have to use the prefs or can a program override it? I have not found errors up to now (except the wbrun problem related only to magellan). Also Scalos boots and all seems to work.
« Last Edit: June 26, 2022, 05:56:06 PM by OlafS3 »



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #16 on: June 26, 2022, 06:00:59 PM
@OlafS3

Thanks for testing. I don't know if programs can override reqtools settings. From what I saw you have to reboot system for changes to take effect.



OlafS3

  • Senior Member
  • ****
    • Posts: 455
    • Karma: +47/-0
Reply #17 on: June 26, 2022, 06:10:37 PM
@OlafS3

Thanks for testing. I don't know if programs can override reqtools settings. From what I saw you have to reboot system for changes to take effect.

Hippoplayer obviously uses reqtools and the preferences for file requester work



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2120
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #18 on: June 26, 2022, 06:37:53 PM
How are you testing the ReqTools requesters?

ASL preferences changing is not yet implemented.

Sorry deadwood, just getting home now, ReqTools Prefs works fine, you had to reboot the system to see the differences, with OS 3.2 this is not necessary.

To test the various FileRequests I use "Eagle Player", this app lets you choose which File Request you want to use between Req.library, Asl.library and ReqTools.library, see screenshot !


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #19 on: June 26, 2022, 06:46:34 PM

Sorry deadwood, just getting home now, ReqTools Prefs works fine, you had to reboot the system to see the differences, with OS 3.2 this is not necessary.


Ok, good that this is sorted out and working :)



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2120
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #20 on: June 26, 2022, 07:09:59 PM
Hi,

https://axrt.org/development/asl_versions-m68k.zip

asl.library.50.7 is the default AROS version that was present in latest releases
asl.library.50.8 contains first half of MorphOS changes
asl.library.50.9 contains first and second half of MorphOS changes


asl.library v50.8 and asl.library v50.9 work great and fix the bugs I reported, now the RequestFile has a proper size, with MysticView now folders and files are highlighted when you scroll with Mouse wheel or Slide window

The new Dimension produced by Als.library 5.08 with EaglePlayer seems not to work, but it is not a problem, maybe it uses its own internal one !


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #21 on: June 26, 2022, 07:52:03 PM
Good. Today seemed to be a good day for resolving bugs and issues ;)



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2120
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #22 on: June 26, 2022, 08:46:53 PM
I discovered another oddity, on your 68k ISO if you do "Leave Out" to an icon, to see the link on Wanderer you have to reboot the system, same thing for "Put Away"

On my AROS One 68k "updated with your ISO" it behaves differently, "Leave Out" and "Put Away" work perfectly without the need to reboot the system, who does the magic?

On your x86 ISO this does not happen
« Last Edit: June 26, 2022, 09:05:09 PM by AMIGASYSTEM »



OlafS3

  • Senior Member
  • ****
    • Posts: 455
    • Karma: +47/-0
Reply #23 on: June 27, 2022, 09:42:49 AM
I just found one problem. If I open a application (the same should be true for games or demos) that opens ECS screen and closes it then UAE crashes. With the old roms it correctly returned to OS



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2120
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #24 on: June 27, 2022, 09:27:13 PM
@deadwood

WBRun of your ISO Does not work, if you run it from a Shell WinUAE crashes ! 2021 version works fine.


deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #25 on: June 27, 2022, 09:58:54 PM
@OlafS3, @AMIGASYSTEM

Thanks for reports. I will look into those after I'm done with ASL.



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #26 on: June 30, 2022, 04:01:50 PM
I just found one problem. If I open a application (the same should be true for games or demos) that opens ECS screen and closes it then UAE crashes. With the old roms it correctly returned to OS

Can you link me an example of such application? I tried Andy and Blondie demo and didn't get a crash. Which ROMs do you mean as "old" - can you point me to archive you got the "old" ROMs from?



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #27 on: June 30, 2022, 05:06:49 PM
Try WBRun from this build: https://build.axrt.org/download/builds/AROS-ABIv11/amiga-m68k-20220630-160607.tar.gz

The problem similar to WBRun is present in several shell commands - I suggesting updating the complete C: drawer.



deadwood

  • AROS Developer
  • Legendary Member
  • *****
    • Posts: 1063
    • Karma: +104/-0
Reply #28 on: June 30, 2022, 06:36:34 PM
FYI, I published m68k Contrib archive matching m68k builds from my build server:

https://axrt.org/download/aros/v11/AROS-20220630-1-any-m68k-contrib.tar.bz2



AMIGASYSTEM

  • Legendary Member
  • *****
    • Posts: 2120
    • Karma: +48/-1
  • AROS One
    • AROS One
Reply #29 on: June 30, 2022, 06:46:34 PM
Try WBRun from this build: https://build.axrt.org/download/builds/AROS-ABIv11/amiga-m68k-20220630-160607.tar.gz

The problem similar to WBRun is present in several shell commands - I suggesting updating the complete C: drawer.

This version of WBRun works well

Even the old native AROS versions I had on my old AROS One 68k worked fine