Icaros - Native installation and internet browsing

eraw · 320

eraw

  • Newbie
  • *
    • Posts: 20
    • Karma: +20/-0
on: April 07, 2022, 11:09:15 AM
Hi,

Ive installed native Icaros 2.3.
First, I like it much and wait for the next releases.

My network is running, ping works, GUI 1920x1080 works good, sound etc.

Now, the biggest problem to me is surfing the web.
OWB fails to start with a ahci error, like other stuff too e.g. copying big files.
The AmigaForever Workbench runs and the AWeb-Browser but there is no network at the moment.
A simple links/lynx/etc shell browser is better then nothing, but I've non working.

Thanks for help and greetings.
 ;D
« Last Edit: April 07, 2022, 11:24:35 AM by eraw »



eraw

  • Newbie
  • *
    • Posts: 20
    • Karma: +20/-0
Reply #1 on: April 07, 2022, 11:45:49 AM
wow, I've found and tested the experimental-update--2.3 iso.
Odyssey works with it.
I will report more later.



salvo

  • Legendary Member
  • *****
    • Posts: 1883
    • Karma: +22/-4
  • Peace an Love
Reply #2 on: April 07, 2022, 02:03:47 PM
you have to select the ide setting for the sata devices from the bios and redo the installation

you are welcome

ps. the achi sub system there is not complete

IcarosDesktop on HP Z400 Workstation


eraw

  • Newbie
  • *
    • Posts: 20
    • Karma: +20/-0
Reply #3 on: April 07, 2022, 03:19:27 PM
Thanks, I will test it now.



Glinx

  • Junior Member
  • **
    • Posts: 82
    • Karma: +28/-0
Reply #4 on: April 07, 2022, 06:44:54 PM
If your sata bios doesn't support true ide mode, try leaving it on ahci and copy odyssey into ram disk before running.

Edit;  I wonder if you're having the same experience that I had..
https://ae.amigalife.org/index.php?topic=879.msg10180#new

Unfortunately, changing bios from ahci to ide may need a fresh install
« Last Edit: April 07, 2022, 07:04:58 PM by Glinx »

Retired.. and working harder than ever


eraw

  • Newbie
  • *
    • Posts: 20
    • Karma: +20/-0
Reply #5 on: April 07, 2022, 07:31:01 PM
My old x86_64 here can operate sata as ide.
Ive now a good useable system and check more out now.
Cool, to see the amiga with forks growing over the time up.
Surfing makes sometimes SSL errors, I search now the forum.



salvo

  • Legendary Member
  • *****
    • Posts: 1883
    • Karma: +22/-4
  • Peace an Love
Reply #6 on: April 07, 2022, 07:35:47 PM
you have to replace the certificate in the owb directory

IcarosDesktop on HP Z400 Workstation


Glinx

  • Junior Member
  • **
    • Posts: 82
    • Karma: +28/-0
Reply #7 on: April 07, 2022, 07:48:40 PM
Excellent!! :)

Retired.. and working harder than ever


eraw

  • Newbie
  • *
    • Posts: 20
    • Karma: +20/-0
Reply #8 on: April 07, 2022, 08:10:34 PM
Great!



salvo

  • Legendary Member
  • *****
    • Posts: 1883
    • Karma: +22/-4
  • Peace an Love
Reply #9 on: April 07, 2022, 10:05:26 PM
use this version of odyssey html5 player is enabled, the actually version on icaros do not it

http://archives.aros-exec.org/share/network/browser/owb-1.25.i386-aros.zip

and replace the executable with this archive

http://archives.aros-exec.org/share/network/browser/odyssey-1.25-11.i386-aros.zip

IcarosDesktop on HP Z400 Workstation


eraw

  • Newbie
  • *
    • Posts: 20
    • Karma: +20/-0
Reply #10 on: April 07, 2022, 10:15:29 PM
Mercy  8)